You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
This will be accomplished using PyPi's 'yank' function. The packages will not be removed, and pip and uv will still be able to install them, so projects with a version pinned >=2.0.0,<2.2.0 will not break, but the installer will log a WARN message about them being deprecated. This will also happen if such a version is required as a transitive dependency. Any new installs which do not pin a version <2.2.0 will automatically receive a version >=2.2.0.
Version 2.2.0 code is backwards compatible from a code interface standpoint, so users do not need to modify their application code to incorporate the new version.
The backwards-inconsistent changes to output data are:
Some Allele objects which previously would have come out with a .state being a LiteralSequenceExpression will now come out with a .state being a ReferenceLengthExpression.
VCFs annotated with reference alleles included in the VRS annotations will need to re-annotate their VCFs if any variants in them (ref or alt) are reference-derived and fall under the ReferenceLengthExpression logic explained in the normalization specification. Ref alleles are always reference-derived, so if the annotation was not run with --skip-ref, those annotations will come out differently in vrs-python versions >=2.2.0. After upgrading to >=2.2.0, the VCF Annotator will include new INFO fields which contain the values necessary for re-constructing the ReferenceLengthExpression object.
Installer warning when doing pip install requiring a yanked version:
WARNING: The candidate selected for download or install is a yanked version: 'ga4gh-vrs' candidate (version 2.0.1 at https://files.pythonhosted.org/packages/42/a7/f50db82d7e8a4bf9dddf8a0ce8deb0ac489d4d3218225692197fe8b90422/ga4gh_vrs-2.0.1-py3-none-any.whl (from https://pypi.org/simple/ga4gh-vrs/) (requires-python:>=3.10))
Reason for being yanked: https://github.com/ga4gh/vrs-python/issues/577, https://github.com/ga4gh/vrs-python/issues/587
Installer warning when doing uv pip install requiring a yanked version:
warning: `ga4gh-vrs==2.0.1` is yanked (reason: "https://github.com/ga4gh/vrs-python/issues/577, https://github.com/ga4gh/vrs-python/issues/587")
Activity
theferrit32 commentedon Dec 18, 2025
The "reason" string in the yank notes will simply link back to the relevant issues.
theferrit32 commentedon Dec 18, 2025
Installer warning when doing
pip installrequiring a yanked version:Installer warning when doing
uv pip installrequiring a yanked version:korikuzma commentedon Dec 18, 2025
@theferrit32 I'm wondering if this should be converted to a discussion?