Skip to content

Bump golang.org/x/net to v0.61.0 and related x/* deps - #286

Closed
surlymochan wants to merge 2 commits into
apache:mainfrom
surlymochan:bump/x-net-x-crypto
Closed

surlymochan wants to merge 2 commits into
apache:mainfrom
surlymochan:bump/x-net-x-crypto

Conversation

@surlymochan

Copy link
Copy Markdown

What

Bumps golang.org/x/net v0.56.0 → v0.61.0 (HTTP/2 advisories fixed in v0.60.0+), and refreshes the related x/text (CVE-2026-56851), x/crypto, x/sys, and x/sync releases those pulls require. go directive moves to 1.26.0 to match other SkyWalking Go modules on the same toolchain.

Test

  • go build ./... passes
  • go test for non-Maven packages passes (pkg/deps Maven resolution needs mvn/mvnw in the environment; unchanged by this bump)
  • govulncheck ./... no longer reports the x/net or x/text advisories. Remaining finding is the unfixed x/crypto/openpgp advisory (N/A fixed version), unrelated to this bump.

surlymochan and others added 2 commits October 17, 2026 16:30
x/net v0.56.0 is affected by HTTP/2 advisories fixed in v0.60.0+.
Also refreshes x/text (CVE-2026-56851), x/crypto, x/sys, and x/sync
pulled in by those releases.

go build ./... and non-Maven packages' tests pass. govulncheck is
clean for x/net and x/text; remaining openpgp finding is unfixed
upstream in x/crypto and unrelated to this bump.
x/net v0.60.0+ requires Go 1.26, so align the license-eye-check workflow,
the Dockerfile builder image, and golangci-lint (v2.9.0 is the first
release built with Go 1.26) with the go directive.
@surlymochan

Copy link
Copy Markdown
Author

CI was failing because x/net v0.60.0+ requires Go 1.26 while the lint job ran golangci-lint v2.6.1 (built with Go 1.25) and license-eye-check pinned Go 1.25. Pushed a follow-up that moves golangci-lint to v2.9.0 (first release built with Go 1.26; golangci-lint run ./... reports 0 issues locally), and bumps the workflow and Dockerfile builder image to Go 1.26.

wu-sheng added a commit that referenced this pull request Oct 18, 2026
golang.org/x/net v0.56.0 is affected by the HTTP/2 advisories fixed in
v0.60.0 (GO-2026-6603/6610/6611/6612/6617), and x/text v0.39.0 by
CVE-2026-56851 (GO-2026-6629, fixed in v0.41.0). Every fixed x/* release
requires go >= 1.26.0, so move the toolchain to Go 1.27 everywhere:

- go.mod: go 1.27.0; x/net v0.61.0, x/text v0.43.0, x/crypto v0.58.0,
  x/sys v0.49.0, x/sync v0.24.0, x/tools v0.52.0, x/mod v0.42.0,
  x/term v0.47.0.
- action.yml, header/action.yml, dependency/action.yml: setup-go 1.27.
  setup-go exports GOTOOLCHAIN=local, so leaving these on 1.25 would
  fail `make install` for every downstream user of the actions.
- CI workflow, Dockerfile builder image and examples/golang: Go 1.27.
- golangci-lint v2.15.0 (built with go1.27). Install it from
  https://golangci-lint.run/install.sh: the script on the frozen
  `master` branch picks the .sbom.json checksum and fails for every
  release since v2.12.2.
- goconst 1.10 began checking composite literals by default; exclude
  them to keep the previous lint scope. Mark a read-only gemspec
  os.Open as a gosec G703 false positive.
- Repin docker/login-action to v4.6.0. The v4.2.0 SHA was dropped from
  the ASF allow-list, and publish-docker has hit startup_failure on
  main since #284.

Supersedes #286.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant